Web Content Display

Requerimientos

Para ejecutar una aplicación en gvHIDRA, se tiene que disponer de un servidor web capaz de intepretar PHP. A continuación indicamos los primeros pasos para poder trabajar con gvHIDRA. En primer lugar, tenemos que revisar que disponemos de los requisitos mínimos para la instalación. Para ello requerimos de un entorno con las siguientes características:

  • Servidor WEB. Puede ser cualquier servidor, aunque nosotros recomendamos Apache 2.X.
  • PHP. Las versiones 4.2, 4.4 y 5.0 de gvHidra son compatibles con PHP 5.4 y 5.6
  • PEAR. Para el correcto funcionamiento del framework, se requieren una serie de librerías del proyecto PEAR con sus dependencias respectivas. Las requeridas son:
    • MDB2: capa de abstracción sobre la base de datos
    • MDB2_Driver_x: correspondiente al SGBD con el que vamos a trabajar (ó SGBDs).
    • PEAR: sistema básico de PEAR